Unable to connect to the remote server

Jun 10, 2011 at 10:51 AM

I have received the following error message, could you kindly let me know how to fix them please. thanks

There was an exception reading the RSS Feed.
Unable to connect to the remote server
Please Contact Your Administrator

Coordinator
Jun 10, 2011 at 12:26 PM
Edited Jun 10, 2011 at 12:26 PM

Not sure I can answer this without knowing a bit more information about your situation

What RSS feed you're trying to access for example?

Is it internal/external to your network?

Is there a "proxy".. if so, have you set the "default proxy" in the web config?

 

The "Unable to connect to the remote server" basically means that "SharePoint / RSS Web Part" cannot make a "successful network connection" to the RSS feed host.

Jun 10, 2011 at 12:42 PM

Hi,

Trying to access external link such as bbc for example, http://feeds.bbci.co.uk/news/rss.xml?edition=uk

It is an external site, and yes there is an web proxy, I have tried to insert the below line into web.config but it make all my SharePoint site unable to access (500 internal error)

Thanks, R

<defaultProxy>
<proxy
usesystemdefault="false"
proxyaddress="http://proxyaddress:port"
bypassonlocal="true"
/>
</defaultProxy>

From: obilogic [email removed]
Sent: 10 June 2011 13:26
To: Siripan, Ray (CCS)
Subject: Re: Unable to connect to the remote server [obilogicrssreader:260893]

From: obilogic

Not sure I can answer this without knowing a bit more information about your situation

What RSS feed you're trying to access for example?

Is it internal/external to your network?

Is there a "proxy".. if so, have you set the "default proxy" in the web config?

The "Unable to connect to the remote server" basically means that "SharePoint / RSS Web Part" cannot make a "successfull network connection" to the RSS feed host.


This email has been scanned for all viruses by the MessageLabs SkyScan service.


This email and any attachment to it are confidential. Unless you are the intended recipient, you may not use, copy or disclose either the message or any information contained in the message. If you are not the intended recipient, you should delete this email and notify the sender immediately.

Any views or opinions expressed in this email are those of the sender only, unless otherwise stated. All copyright in any Capita material in this email is reserved.

All emails, incoming and outgoing, may be recorded by Capita and monitored for legitimate business purposes.

Capita exclude all liability for any loss or damage arising or resulting from the receipt, use or transmission of this email to the fullest extent permitted by law.
Coordinator
Jun 10, 2011 at 1:27 PM

To allow access to external RSS feeds from your internal Sharepoint site, your need to add your local proxy setting to the web.config correctly.

Change the following lines:
 
<system.net>
  <defaultproxy>
     <proxy autodetect="true" />
  </defaultproxy>
</system.net>
 
to:
 
<system.net>
  <defaultproxy>
     <proxy usesystemdefault="false" proxyaddress="http://YOURPROXYSERVER:PORT" bypasslocal="true />
  </defaultproxy>
</system.net>
 
Run a iisreset after saving the web.config file.

 

Replacing "YOURPROXYSERVER:PORT" with the "IP address" and "port number" of your proxy

If your proxy as IP address like 192.168.100.100 and port 8080, your node should look like

<proxy usesystemdefault="false" proxyaddress="http://192.168.100.100:8080" bypassonlocal="true" />

 

Further info on the <defaultproxy> element can also be found at

http://msdn.microsoft.com/en-us/library/kd3cf2ex.aspx

Jun 10, 2011 at 1:36 PM

Thanks for the info, I have changed the web.config as per your suggestion, after I changed the web.config, I received this error when access any sharepoint website.

Thanks

Description: cid:image001.png@01CC277B.4FC17180

From: obilogic [email removed]
Sent: 10 June 2011 14:28
To: Siripan, Ray (CCS)
Subject: Re: Unable to connect to the remote server [obilogicrssreader:260893]

From: obilogic

To allow access to external RSS feeds from your internal Sharepoint site, your need to add your local proxy setting to the web.config correctly.

Change the following lines:

<system.net>
<defaultproxy>
<proxy autodetect="true" />
</defaultproxy>
</system.net>

to:

<system.net>
<defaultproxy>
<proxy usesystemdefault="false" proxyaddress="http://YOURPROXYSERVER:PORT" bypasslocal="true />
</defaultproxy>
</system.net>

Run a iisreset after saving the web.config file.

Replacing "YOURPROXYSERVER:PORT" with the "IP address" and "port number" of your proxy

If your proxy as IP address like 192.168.100.100 and port 8080, your node should look like

<proxy usesystemdefault="false" proxyaddress="http://192.168.100.100:8080" bypassonlocal="true" />

Further info on the <defaultproxy> element can also be found at

http://msdn.microsoft.com/en-us/library/kd3cf2ex.aspx


This email has been scanned for all viruses by the MessageLabs SkyScan service.


This email and any attachment to it are confidential. Unless you are the intended recipient, you may not use, copy or disclose either the message or any information contained in the message. If you are not the intended recipient, you should delete this email and notify the sender immediately.

Any views or opinions expressed in this email are those of the sender only, unless otherwise stated. All copyright in any Capita material in this email is reserved.

All emails, incoming and outgoing, may be recorded by Capita and monitored for legitimate business purposes.

Capita exclude all liability for any loss or damage arising or resulting from the receipt, use or transmission of this email to the fullest extent permitted by law.
Jun 10, 2011 at 1:59 PM

Thanks, all working now, case sensitive on the web.config

From: obilogic [email removed]
Sent: 10 June 2011 14:28
To: Siripan, Ray (CCS)
Subject: Re: Unable to connect to the remote server [obilogicrssreader:260893]

From: obilogic

To allow access to external RSS feeds from your internal Sharepoint site, your need to add your local proxy setting to the web.config correctly.

Change the following lines:

<system.net>
<defaultproxy>
<proxy autodetect="true" />
</defaultproxy>
</system.net>

to:

<system.net>
<defaultproxy>
<proxy usesystemdefault="false" proxyaddress="http://YOURPROXYSERVER:PORT" bypasslocal="true />
</defaultproxy>
</system.net>

Run a iisreset after saving the web.config file.

Replacing "YOURPROXYSERVER:PORT" with the "IP address" and "port number" of your proxy

If your proxy as IP address like 192.168.100.100 and port 8080, your node should look like

<proxy usesystemdefault="false" proxyaddress="http://192.168.100.100:8080" bypassonlocal="true" />

Further info on the <defaultproxy> element can also be found at

http://msdn.microsoft.com/en-us/library/kd3cf2ex.aspx


This email has been scanned for all viruses by the MessageLabs SkyScan service.


This email and any attachment to it are confidential. Unless you are the intended recipient, you may not use, copy or disclose either the message or any information contained in the message. If you are not the intended recipient, you should delete this email and notify the sender immediately.

Any views or opinions expressed in this email are those of the sender only, unless otherwise stated. All copyright in any Capita material in this email is reserved.

All emails, incoming and outgoing, may be recorded by Capita and monitored for legitimate business purposes.

Capita exclude all liability for any loss or damage arising or resulting from the receipt, use or transmission of this email to the fullest extent permitted by law.